Renault Forums :: Independent Renault forum - View Single Post - Fitting of TDC Sensor*Fixed*

View Single Post
post #6 of (permalink) Old 8th August 2008
Platinum member
Join Date: Aug 2005
Posts: 14,145
Nominated 2 Times in 3 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 68 Times in 26 Posts
Originally Posted by DeeBeeS View Post
Well just to finish my story I replaced the TDC sensor, wired it all up and quess what? it wouldn't work, car did not start just turned ever, I had cut the wires to put on the new connection so I was in a difficult position, any way I spent several hours taking it out and putting it back in but still no luck.

By this time my hands were cut to pieces. I must point out that when I got the new sensor the packet was already opened and there was some slight grease mark on it but it looked new so I thought it was alright.

I then replaced the old one and botched up the wire connections and I got it to work.

The next day I drove about 20 miles to the Renault dealer where I had got it from(that's the nearest) and they accepted that the sensor was faulty but did not have any more in stock. I was asked to return the following day when one would be available.

Prior to going I telephoned and confirmed that the part had arrived and went out to collect it. The exchange was done without any problems and this time the packet was unopened. As I left the Renault dealer the man who had served me came running out and gave me a 5 litre can of synthetic oil and apologised for the inconvenience caused.

I wonder if this was an admission of gullt or a nice gesture. I will remember in future not to accept these opened packs. I have fitted the second one which worked first time.

Glad you got it sorted after a lot of hassle DeeBeeS.

Thanks for keeping us updated
ottoman is offline  
For the best viewing experience please update your browser to Google Chrome