Renault Forums :: Independent Renault forum - View Single Post - Where do I stand and what do I do?

View Single Post
post #30 of (permalink) Old 13th August 2008 Thread Starter
Platinum member
stef123's Avatar
Join Date: Sep 2007
Posts: 2,299
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 50
Thanked 40 Times in 31 Posts
Send a message via MSN to stef123
Originally Posted by madnoel10 View Post
Definitely sounds like the ABS ain't working as it should - could be a electrical fault. If the ABS ain't working correctly it will go into default mode and the wheels will lock up under heavy braking. This is usually accompanied by an ABS warning lamp but if the fault is intermittent it may not do so. For your safety and the safety of other road users I suggest you have it checked out.
I don't know about Ford but I know on my Laguna no matter how hard I stamp on the brakes the wheels don't lock. Also it could be a bit embarassing if the road surface was proved to be OK and then you discover a brake fault.
I will definetly have that looked into anything I can do myself here?

I've just read on a website that all focus 1.6's up until 2003 don't have ABS. could anyone say if this is true or not? Apparently they still have the wheel sensors fitted though? I could have bought a car under false advertisement here..whatever it gets called..
Currently in stef123's garage:
2006 Ford Mondeo ST TDCI

Last edited by stef123; 13th August 2008 at 05:56 PM.
stef123 is offline  
For the best viewing experience please update your browser to Google Chrome