Renault Forums :: Independent Renault forum - View Single Post - II-In Dash LCD Replacement*Fixed*

View Single Post
post #3 of (permalink) Old 15th August 2008 Thread Starter
shelster's Avatar
Join Date: Jan 2008
Posts: 75
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

I love it when things turn out good.

Have finally fixed the in dash sisplay and now have full sat nav capability back in the car. There is no radio info displayed, but can get over that as the new HU displays a hell of a lot more than the display did.

Turns out, that when the guy installed my new HU, he took the ISO loom rom the boot and re ran it up the passenger side of the car in tothe centre console. In doing so, he also took the red connector that was in the loom with it. From what i can gather from looking at the drawings and my engineering mind, this carried the data from the central control computer (the one with the wheel and m and c buttons) back to the amp.

I then ripped my car to bits to get the connector back and re fitted that and the blue and yellow connectors onto the amp.

Was wondering if i then needed to power the amp, but noticed that the display had sprung to life with juts that connected.


So all is now good in the world, until the next major catastrophie.

I also noticed that the negative wire was actually floating in space, not connected to anything. Seems that the ground return was happening through the aerial.
Currently in shelster's garage:
2008 Clio 1.5 tDI Initiale
shelster is offline  
For the best viewing experience please update your browser to Google Chrome