Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2 - 1.9 Diesel,Changing Pump Info*FIXED*

View Single Post
post #17 of (permalink) Old 17th August 2008 Thread Starter
Junior Member
armalite8's Avatar
Join Date: Mar 2007
Posts: 28
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Sorry yes, forgot to update this thread as I'm also having a 'bit of a time' with our Scenic DCi (Devils Car Incarnate).

The Bosch pump went on a treat. As it had come off a Clio F8Q and the injectors on mine were marked up as 130bar, I left them in situ (which is the spec for Bosch pumps not Lucas, so I suspect a previous swap in it's lifetime).

It took a while to bleed all the air through and I had to extend the fuel supply line, and remove the immobiliser on the pump, but it pretty much fired up first turn. A bit lumpy for a while, which I assume was air coming through, but smoothed up after about 100 miles.

Now runs on 60% veg oil 40% dino-derv all the time. I have gone as far as 90% vegoil in the hot spell, but only to get to the petrol station. It was a bit rough cold, but no different once it warmed up. Always starts straight away.

This engine has the diesel pre-heater in the filter, and when I extended the fuel hose I inserted a home made pre-heater as well that I had from my old Volvo. Once that's plumbed in I may well go to 70/30 or more.

If anything it's smoother and quieter on veggy, although as I said a bit lumpy for the first couple of minutes and it does smell like a roadside cafe.

All in all very pleased. If only the Scenic was as easy to look after....
Currently in armalite8's garage:
Lag1 2.2D. Have killed a Clio 1.9D, Lag 1 2.2dt and 1.8RT
armalite8 is offline  
For the best viewing experience please update your browser to Google Chrome