Renault Forums :: Independent Renault forum - View Single Post - Renault Espace - Instrument panel

View Single Post
post #1 of (permalink) Old 22nd September 2008 Thread Starter
Junior Member
scannelldd's Avatar
Join Date: Nov 2007
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Espace - Instrument panel

Hi guys, I've got a W reg Grand espace. The instrument panel works fine, but there is a big red blob where the time is displayed, which is most annoying. I've searched around and picked up an identical replacement, i.e. with exact part no. but when I put it in over weekend odd things happened. At first it was ok, then when I put indicators on the whole display flashed, and then it went blank. After a few minutes and with ignition turned off, then on again, it would work and then do same again indicator wise. Also I then fond my key fob wouldn't lock / unlock the doors. I don't know whether this replacement is ok or whether it is faulty, i expect it would be difficult to get it checked out. The milage displayed was the milage on my car however. I've put the old unit back in, but can anyone help me as to what's going on.

To update the above, just to let you know how i resolved my problem, as I couldn't use this replacement panel as a unit, I took all the casings off and found that the small LED display where the clock was shown was relatively easy to remove as unit, it just had two electrical connectors into the electical panel behind it, so i unclipped this and did a straight swap with my own one, and when I put it back together Hey Presto I could see my clock display again. I'd still like to know why the panel itself didn't work with the key fob, and I'm sure others would also, but I've got the result I was after having spent 20 on ebay . Might even get it back as I've just listed it on ebay myself, fully explaining what i've done and that there is this 'blob' on the clock display.
Currently in scannelldd's garage:
2000 Grand Espace RXE 3.0 V6

Last edited by scannelldd; 16th October 2008 at 08:52 AM. Reason: Information for others as to my resolution
scannelldd is offline  
  5 Lastest Threads by scannelldd
Thread Forum Last Poster Replies Views Last Post
2005 megane, keyfob not automatically unlocking Electronics scannelldd 0 696 10th February 2013 02:59 PM
Renault Espace - Instrument panel Electronics mattprice 10 4179 22nd September 2008 10:45 AM
For the best viewing experience please update your browser to Google Chrome