Renault Forums :: Independent Renault forum - View Single Post - 2004 1.6 petrol loss of power

View Single Post
post #1 of (permalink) Old 24th October 2008 Thread Starter
Junior Member
Join Date: Oct 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
2004 1.6 petrol loss of power

I have a 2004 Scenic, its a 1.6 16v petrol privilage model, has 78000 miles and has been fully serviced. however i dont think the timing belt has been changed yet, looks in good condition though. i am in the process of trying to get a detailed service log as its been a fleet car.

Anyway the problem is there is just a lack of power. it started a week or so ago and just got worse. its as if its being held back by something. i have seen mentioned on other sites an idle setting mentioned, this would make sense. in 1st and 2nd the engine is much louder than normal. It manages to get upto about 60mph at tops. it has been back to the garage today and they said its not the coils , as i had thought and hoped, but it is coming up with an emissions problem.

As im currently a bit skint like most i would like to find out whats wrong, and if i can fix the problem myself.

Any help or advice would be much appreciated.

Kind Regards
Currently in sward1975's garage:
2004 Scenic 1.6 petrol privilage
sward1975 is offline  
  5 Lastest Threads by sward1975
Thread Forum Last Poster Replies Views Last Post
2004 1.6 petrol loss of power Electronics ottoman 1 632 24th October 2008 04:13 PM
For the best viewing experience please update your browser to Google Chrome