Renault Forums :: Independent Renault forum - View Single Post - TDC Sensor Replacement (with pictures!)

View Single Post
post #145 of (permalink) Old 30th October 2008
Junior Member
Megane2000's Avatar
Join Date: Oct 2008
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi All:

Well it took me a while but... I fixed it!!!!

I can not download the pictures from the phone now, but the history was the following:

-I got the tools and the TDC sensor from my local parts shop. Sadly the new TDC sensor had the old connector, the black one that you see in the photos of this Thread, but my Megane had a blue one that do not mach. Why?. Because my car was on May on Renault, you can see in my previous post, and they use the blue TDC part and the blue loom.

So back to Autocare, they checked with Renault and they kindly explain me all the details. (Thanks Peter...). I got my money back, when to Renault Parts and I got the TDC , the one with he blue connector and the loom... FOR FREE!!! They honor the warranty of the parts on my last visit (Thanks Dermont and Renault Sandyford).

Back to my car, put the TDC sensor,put back air filter, deep breath and turn on the car. It took me 3-4 tries before it started fine. Not warning lights on the dahboard and a few miles to rechard the battery.

I am sorry for the long post.

Thanks to all the people that helped me with this Thread and the photos.

Megane2000 is offline  
For the best viewing experience please update your browser to Google Chrome