Renault Forums :: Independent Renault forum - View Single Post - Windscreen Wiper Motor Squeek

View Single Post
post #1 of (permalink) Old 29th November 2008 Thread Starter
likely_laguna's Avatar
Join Date: Nov 2008
Posts: 84
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question Windscreen Wiper Motor Squeek

* If this isn't the best place please move this post *

My wiper has been squeaking which drives me nuts - coupled with the fact I had no radio following the incorrect code in the book after changing the battery and drove 4 1/2 motorway hours with the squeal for company in the rain.

I digress - initially I thought it was the blades on the windscreen so tried lots of tricks, cleaning the wipers, windscreen, using vinegar and more. I then lifted the wipers and ran them - the scream was still there!

It sounds like the centre motor, I've just lubed it up but can't really get 'into' it to do it properly. And it's well below freezing and dark outside.

Has anyone encountered this before, is there a quick and simple solution? Any advice and comment is welcome!
Currently in likely_laguna's garage:
2000 Renault Laguna 1.8 Alize
likely_laguna is offline  
  5 Lastest Threads by likely_laguna
Thread Forum Last Poster Replies Views Last Post
Windscreen Wiper Motor Squeek Bodywork likely_laguna 5 1912 29th November 2008 05:01 PM
Laguna II Not Starting - Help? Engines dave_mezza2006 19 3100 20th November 2008 03:21 PM
For the best viewing experience please update your browser to Google Chrome