Renault Forums :: Independent Renault forum - View Single Post - Laguna I Phase II - 1.9 RT, R Reg

View Single Post
post #4 of (permalink) Old 22nd December 2008
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
Originally Posted by Saveman View Post

Not sure if this is the right section or not, please move to appropriate section, sorry if i got it wrong.

I just bought an R Reg Laguna 1.9 RT.......I wasn't planning to buy it but a holiday disaster forced us to just grab the best cheapest car we could and now we've got a Lag sitting in the driveway. Mileage is 198000ish so its been around the block.

Few issues:

The remote central locking works but if the key is inserted in the door the lock just spins.

The boot carpet is soaking.....hence constant misting of windows

The cd player lights up when switched on but no sound comes through.

The central display console remains blank all the time, temp etc.

When the engine is switched off something bangs underneath.....engine cover? exhaust?

Apart from all those things.....this seems like a really nice car! Any and all suggestions for fixs are gratefully accepted! Thank you
Hello and welcome to the forum.

I suspect that the back light bulbs have blown in the head up display,if you replace them (easy job to do,there are some instructions on here if you need them),and then I suspect that your radio will be asking for a code.

I suspect that the door lock just needs lubricating.The parts inside the barrel seize due to lack of use and this causes the barrel to spin.I soaking in WD40 or similar may help,if not then the lock will need to be dismantled and cleaned.

The boot carpet sounds like the taligate seal is leaking,an easy fix.

The banging underneath is probably a poorly aligned exhaust.They are buggers for this,there is little clearance between the exhaust and body and even if it's lined up ever so slightly wrongly it will knock.If the exhaust looks OK,then it maybe a worn engine stabiliser,if you search for this on the forum you should be able find some info on changing it.

Any more help you need,please don't hesitate to ask.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
For the best viewing experience please update your browser to Google Chrome