Renault Forums :: Independent Renault forum - View Single Post - Speedo

Thread: Speedo
View Single Post
post #3 of (permalink) Old 29th December 2008
Diamond member
root-two's Avatar
Join Date: Nov 2007
Posts: 188
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to root-two
Here's a little trick I saw posted on t'Internet somewhere (wish I could remember where, though!) - it works on the Mk2 Clio, and may work for other Renaults with digital/electronic speedos as well:

If you suspect that your speedo sensor may be faulty, do the following:
  • Press the trip reset button, and keep it pressed down.
  • Turn on the ignition - keep the trip reset button pressed for 4-5 seconds.
  • Your trip and total mileage will then show all 8s and the speedo, rev counter, fuel and temperature gauge will go into 'test mode' - you'll see the needles on these gauges moving up and down through their range (eg. 20, 40, 60mph, fuel empty, 1/4, 1/2 etc.)
  • To leave 'test mode' just press the trip reset again - displays etc. will return to normal.

If it's the speedo sensor that's at fault, then none of the above will happen - the downside is that it's not really a lot of use if you've got an intermittent fault (as I have - car is going in on the 8th for a new speedo sensor)

This may be common knowledge, of course, but was news to me


"No performance at all is vastly preferable to an obscene travesty" - Kaikhosru Shapurji Sorabji
Currently in root-two's garage:
1999 Clio 1.2RN Grande (D7F)
root-two is offline  
For the best viewing experience please update your browser to Google Chrome