Renault Forums :: Independent Renault forum - View Single Post - Modus Radio/Dashboard fault

View Single Post
post #4 of (permalink) Old 8th January 2009
Junior Member
Join Date: Mar 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Originally Posted by Wychall View Post
The radio on my 2007 Modus has stopped working, evidently no power. The fuses are all fine, but the most perplexing symptom is that the time and temperature displays on the dashboard are now permanently illuminated.
Does anyone have any experience of this or do I need to get Renault to computer diagnose it?
I currently have the exact same problem - has your battery gone flat yet? - I paid ***8364;250 to have my battery replaced in Germany 2 weeks ago - radio stopped working one day battery flat the following day. Same thing happened on Tue this week radio dead, yesterday battery went flat. On contacting Stealer they confirmed that this is a known problem with the radio thermal cut out, designed to prevent overheating but on some radios it cuts out when cold but as power for the dash passes through it it leaves the feed permanently on thereby illuminating the temp and clock and draining the battery! solution was to remove radio & send for repair or replacement - all covered under warranty.
Currently in senicx3's garage:
Grand Scenic 1.6 Oasis, Megane 1.5 dci Dynamique

Last edited by senicx3; 8th January 2009 at 05:04 PM.
senicx3 is offline  
For the best viewing experience please update your browser to Google Chrome