Renault Forums :: Independent Renault forum - View Single Post - Lag II Xenon Lights Failure

View Single Post
post #1 of (permalink) Old 10th January 2009 Thread Starter
The Saint
Diamond member
Join Date: Sep 2006
Posts: 179
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 5 Times in 2 Posts
Send a message via MSN to The Saint
Lag II Xenon Lights Failure

Hi all

The passenger side xenon failed had a read on here so decided to check if it was the bulb and not the ballast, so took the driver side one and put it in the passenger side, light came on for about 10 seconds flickered went bright then failed. Doh!

So the question i have, was I unlucky in that both were about to fail, or is there a problem with the passenger side electrics. I don't wont buy new bulbs only to have them fail.

Any suggestions before i go to auto electrician?

Just ordered a pair of the upgrade bulbs from auto bulbs...
Currently in The Saint's garage:
2001 Renault Laguna II 1.9 Dci ST

Last edited by The Saint; 10th January 2009 at 10:58 AM.
The Saint is offline  
  5 Lastest Threads by The Saint
Thread Forum Last Poster Replies Views Last Post
Laguna II Xenon Light & Battery Electronics davesss 2 2057 5th February 2009 05:47 AM
Noooo its melted.. xenon Warning Electronics The Saint 6 2164 21st January 2009 06:45 PM
Lag II Xenon Lights Failure Electronics The Saint 6 2156 10th January 2009 10:43 AM
Renault Laguna II - Air con dual zone temperatures Heating & cooling saabguy 7 5167 14th September 2008 09:56 PM
Crossed threaded wheel nuts Wheels & tyres madnoel10 1 1539 25th March 2008 05:54 PM
For the best viewing experience please update your browser to Google Chrome