Renault Forums :: Independent Renault forum - View Single Post - Laguna 2 - one side of rear demister not working?

View Single Post
post #1 of (permalink) Old 14th January 2009 Thread Starter
Junior Member
Join Date: Sep 2005
Posts: 29
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Laguna 2 - one side of rear demister not working?

Morning folks -

Had my rear demister on this morning and noticed that it only seemed to clear the driver's side of the boot glass [on an estate / sport tourer]. The other side of the glass seemed to stay misted up.

Is there a demister connection on both sides of the boot hatch, meaning the passenger side one might be faulty?

Cheers for any guidance!

ps sorry if this is in the wrong area - not sure if it comes under electronics or heating / cooling. Please feel free to move.

Last edited by Inchy; 14th January 2009 at 07:32 AM.
Inchy is offline  
  5 Lastest Threads by Inchy
Thread Forum Last Poster Replies Views Last Post
Alpine 6 disc cd changer - removal? Electronics mord 3 3578 1st March 2010 06:12 AM
Renault Laguna 2 - Rear Wiper Not Working Electronics Andreaspeters1 10 13806 11th January 2010 07:18 PM
Laguna II - sat nav in standby mode? Electronics excavator 1 1007 18th May 2009 08:38 AM
Laguna II - is my problem more than just coils? Engines madnoel10 3 1077 18th May 2009 08:34 AM
STP - did the trick for my Laguna 2 Engines Bob925 5 2031 30th January 2009 12:19 PM
For the best viewing experience please update your browser to Google Chrome