Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna I - Phase 1 - Heating and Cooling - Possible fix for cold heater

View Single Post
post #83 of (permalink) Old 18th January 2009
Junior Member
Join Date: Jul 2007
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Alternative method

I park on the street and have no hose nearby, I cleaned my matrix by taking it out first.
To take out the matrix you can follow Haynes. It briefly goes like this:

1) As above, remove the pipe connection. But also remove the two screws that hold the plate with the pipe ends. This will loosen up the pipes on the inside.

2) Remove the glovebox.

3) Find the pipe on the inside. Remove the screw that fixes the pipes, and the screw that secures the coupling with the matrix. Remove the screws that hold the matrix in place (apparently that can be clips here as well depending on model.)

4) Gently slide out the matrix. Some cables and plastics are a bit in the way, but nothing to serious. Careful not to spill coolant. Have a small plastic tray ready.

5) Clean the matrix (in the comfort of your kitchen!). Repeated shaking and flushing with plain water does the trick.

6) Put the matrix back, taking care that the nobs on the matrix slide in the guides.
I filled the matrix with water to prevent airlocks.

So far, so good. It took me about 3 hours.
Currently in cosine's garage:
Laguna 1, 1996 1.8RT
cosine is offline  
For the best viewing experience please update your browser to Google Chrome