Renault Forums :: Independent Renault forum - View Single Post - Definative answer for --- on range/mpg display

View Single Post
post #19 of (permalink) Old 22nd January 2009
Junior Member
rjboodell's Avatar
Join Date: Oct 2008
Posts: 17
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Horatio View Post
I had this happen on a Laguna once that was off the road for a week while the gearbox was rebuilt.

To cut a long story short, the (non-Renault) garage that did the work was stumped, and my local dealer wanted 500 quid for a new instrument cluster. Another dealer subsequently reset the dash for their minimum hourly labour charge, and all of the functions came back.

It's a bit of a long shot, but the panel may have a diagnostic mode that's accessed by holding in the trip computer button (the one that steps through the different displays) while turning on the ignition. There's a chance that this will reset the computer and (hopefully) make the fuel functions come back. I didn't know about it when I had the problem with mine, but it'd be the first thing I'd try now.

If you do give it a shot, then please let us know if it works

I have a Laguna 1 V6 with the computer guy. Everything works fine when I scroll through the displays EXCEPT the fuel remaining readout. Any fix for this... fuse, sensor etc...???
Currently in rjboodell's garage:
1999 Mk1c Laguna RTi V6 24v
rjboodell is offline  
For the best viewing experience please update your browser to Google Chrome