Renault Forums :: Independent Renault forum - View Single Post - faulty sat nav

Thread: faulty sat nav
View Single Post
post #71 of (permalink) Old 25th January 2009
Diamond member
Eeeps's Avatar
Join Date: Oct 2006
Posts: 447
Nominated 0 Times in 1 Post
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 28 Times in 27 Posts
Originally Posted by mikky-mike View Post
Hi bpowell555
No Sat nav all works fine, its just the radio and CD player, it beeps every 3 seconds, and swithes of after 2 minutes, the book tells me thats correct until I enter the code.
I had a new battery about a year ago and as soon as I turned the radio on the 4 zeros come up on the sat nav screen and I entered the code, all worked great, but now after disconnecting the battey, and reconnecting it, I do not get the 4 zeros, so I cannot enter the code, seems very strange.

You may need to re-initialise the Sat Nav so that the display of the radio information works.

1. Switch off the ignition
2. Wait until the Sat Nav shuts down (1 minute or so)
3. Switch the radio on
4. Switch on the ignition and wait about 20 seconds
5. Press the M and C keys together
6. Check the vehicle number (should be 0002 or 0007). If it show 0012 this indicates the radio is not detected.
7. Exit using the rotary switch
8. Switch off the ignition.

If this initialisation is done without the radio switched on then the Sat Nav display will never show the radio information.

Currently in Eeeps's garage:
2011 Clio III dCi 88 Dynamique and 2016 CitroŽn Grand C4 Picasso Exclusive+ EAT6 2.0 BlueHDi
Eeeps is offline  
For the best viewing experience please update your browser to Google Chrome