Renault Forums :: Independent Renault forum - View Single Post - VELSATIS - Rear Fog Lights Not Working

View Single Post
post #1 of (permalink) Old 25th January 2009 Thread Starter
Junior Member
Join Date: Nov 2007
Posts: 20
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
VELSATIS - Rear Fog Lights Not Working

My rear fog lights aren't working, can you suggest where i need to look to fix them.

I tried the obvious bulbs but these are fine as i swopped them with the reversing lights, and so this isn't the problem. Also all the other rear lights in the cluster work...reversing lights / rear lights.

Also tried looking at the fuse, and the loop seemed ok. Even swopped it with another 10 just in case.

Lastly all other lights seem to work ok, including front fog lights.

I was hoping there might be a "usual problem fix" to this one, as it's both lights i think it must be a connection somewhere.

Thanks in advance

BECKS7 is offline  
  5 Lastest Threads by BECKS7
Thread Forum Last Poster Replies Views Last Post
Replacing the hazard warning light switch on a... Electronics MéganeDynamique 7 2714 8th February 2011 11:57 AM
VEL SATIS problems - electric window + radio Electronics Wile7 3 2196 6th October 2010 12:11 PM
VELSATIS - Radio and Sat Nav staying on after... Electronics BECKS7 1 1069 26th March 2009 11:46 PM
VELSATIS - Mileometer problem - showing km not... Electronics saabguy 3 2167 25th January 2009 07:29 PM
For the best viewing experience please update your browser to Google Chrome