Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Electronics - Displaying KMH not MPH

View Single Post
post #49 of (permalink) Old 6th February 2009
Platinum member
Technical Supremo
TTT's Avatar
Join Date: Jun 2008
Posts: 1,948
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 197
Thanked 397 Times in 346 Posts
Originally Posted by mike h View Post
Just bringing this thread up again as im trying to gather some information on fixing this problem with the laguna instrument clusters
could the people who have had this problem email me the car details ie

petrol or diesel
and if the instrument cluster has the computer on not
this will help me to solve the problem

there are different mcu's in the clusters as if the car has the computer or not, its a 908 in the model without the computer and a newer 9s12 in the models with the computer
if i can see which clusters are having the problem i can source a working mph cluster and read the data from that and program into the faulty cluster, and even replace the mcu if it turns out to be faulty


I have some information that may help you with finding a solution to this problem & other dash problems on the Laguna 2.


you can get your dashboard fixed by these people....give them a ring & explain your problem....good luck.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
For the best viewing experience please update your browser to Google Chrome