Renault Forums :: Independent Renault forum - View Single Post - laguna 11 radio and clock not working

View Single Post
post #4 of (permalink) Old 6th February 2009
Junior Member
Join Date: Feb 2009
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Matty.....

read with interest your problem. Long time ago I know but I've just done exactly the same thing...!!! Banging my head off the floor cos the manual sucks and I ain't putting it into a dealer. Did you ever solve it..? and if so, I'd sure appreciate your help on it.

Yours hopefully.... Mars...

Originally Posted by matty3553 View Post
hi frist timer

it would be nice to find out the problem im having with my radio. i pulled the radio out about six weeks ago to look at the fittings at the back to see if the plug would fit another radio that i had? but in doing this a live wire touch the radio and went off. i just thought a fuse had blown but trying to look for the radio fuse was a hilarious because in the owners hand book it didnt seem to have one. i later found out by looking on this site its by the ashtray. ( fuse o.k) back to my problem the radio the clock and the tyre pressure display have all gone off but it comes back on if i take the power lead out of the back of the radio and leave it over night then put the plug back it still working but then when i drive off and it all goes off again ive notice the icon button that unlocks the car by the handbrake the little light is on when the radio is off but when the power is back on that little light is out ive tried to explain as much as i can. please can anyone help me as i need a radio to listen to im going mad listening to the same old songs on my phone thanks matt
Currently in Marslab's garage:
2001 Renault Laguna II 1.9dCi
Marslab is offline  
For the best viewing experience please update your browser to Google Chrome