Renault Forums :: Independent Renault forum - View Single Post - 2006 Traffic deisel van - lack of power

View Single Post
post #2 of (permalink) Old 27th February 2009
Platinum member
Join Date: Mar 2006
Posts: 1,854
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 2
Thanks: 6
Thanked 15 Times in 15 Posts
Originally Posted by 100949football View Post
have 2006 Traffic 2.5 deisel van and have had problems re loss of power around 50-60mph which is very worrying.
The speedo did not work and the abs warning light AND deisel glow plug lights were staying on.
An autio electrician spent an entire day on the van and replaced the speedo cable (which apparently goes through the abs system). Thas got the speedo working again but the lack of power remains.
Can't get the van to go above 50-60mph with disturbing lack of power around those speeds.
The van has been regularly serviced but done over 130,000 miles.

Any help/ideas would be wlecomed.
Have you checked the obvious? Air filter, diesel filterS, egr valve etc? If it only happens at speed, I'm inclined to think it is fuel/air-related.

P.S. Just remembered something else... An exhaust system leak under the bonnet will cause loads of carbon black to be sucked into your air filter element which gradually gets blocked.

They only called me "diesel fitter" because whenever we had shoes in the warehouse, I'd pick up some size 5s and say, "These'll fit 'er!"

Confucius he say "Wise Inuit never eats yellow snow"
Currently in vass20's garage:
Citroen Relay 2.2 HDi + Citroen C4 1.6 HDi EGS

Last edited by vass20; 27th February 2009 at 09:55 AM. Reason: ps added
vass20 is offline  
For the best viewing experience please update your browser to Google Chrome