Renault Forums :: Independent Renault forum - View Single Post - 2006 Traffic deisel van - lack of power

View Single Post
post #4 of (permalink) Old 27th February 2009
Platinum member
Join Date: Mar 2006
Posts: 1,854
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 2
Thanks: 6
Thanked 15 Times in 15 Posts
Originally Posted by 100949football View Post
Thank you VASS20

The van has recently had a big service and all these items were replaced, serviced, chacked.
One common factor is the deisel "glow plug' light on the dash. When this is OFF the van runs fine, then at speed the "glow plug" light comes on and badly affects performance UNTIL the engine switched off again. Then the cycle reoccurs.

Any further ideas would be appreciated.

regards bill
Hello Bill,

Ignition on a diesel is done by very high compression (typically 22:1). The glow plugs are only useful on a first start especially on a cold morning; hence I don't understand the relationship between the glow-plug warning light and cutting out or losing power when running at >55 mph. My 2.2 HDi Relay never needs to wait for the plugs to warm up, for example; I just turn the key and it goes first turn.

Are you up for opening the air-filter box and checking that the element really did get replaced during the service? It's not unknown for mechmaniacs to be "forgetful" when trying to meet a time schedule. Also, if there are diesel fumes under the bonnet, these can cause an element to block up very quickly (black deposit will be evident on a paper element).

The high-pressure diesel pump could also have a blocked filter or a leak meaning that it is not maintaining sufficient internal pressure when diesel is being used up more quickly, as happens at high speed. I'm not sure what in-line filters they have pre-pump and post-pump, but if the vehicle has ever run out of fuel or is habitually run in the red-zone of the fuel guage, it is more likely to be effected by a pre-filter blockage. So, if you've ever run out of diesel, look at that first. Some bio-fuels are not as clean as they could be, nor is chip-pan oil , so you have to take this into account too, if you are not the only one driving it and filling it up.

I think the sensors would give fault warnings at all speeds not just at high ones. This light you're getting could be a false positive cause by a short or bad earth even. As far as I know, glow plugs turn themselves off once the engine is running, but I've heard of some that do stay on (for what reason, I do not know though).

I take it that you've checked the injector supply pipes for any leakage. Don't rely on the fact that it has just been serviced no matter how much you believe in them; everyone is subject to making mistakes. Renault had my V6 Laguna once for a change of ignition coils and left the high-pressure pipe unlocked which cause a big petrol spill all over my engine and could have caused a major disaster. So, take a look yourself and toggle a few things if they look like thev've been touched during maintenance.

Are you sure it's the glowplug light and not "water-in"diesel" warning? I'm not familiar with the Master so I may be firing blanks here.

On an old-style diesel I would have said that your diesel and air supply were the only things worth checking, but with all the sensors that modern engines have, there might be others who have ideas that differ from mine.

I hope some of this helps and you can get it sorted quickly. Best of luck.

Confucius he say "Wise Inuit never eats yellow snow"
Currently in vass20's garage:
Citroen Relay 2.2 HDi + Citroen C4 1.6 HDi EGS
vass20 is offline  
For the best viewing experience please update your browser to Google Chrome