Renault Forums :: Independent Renault forum - View Single Post - LAG 03 Sat Nav Display very dim, but working

View Single Post
post #1 of (permalink) Old 21st March 2009 Thread Starter
Junior Member
Join Date: Mar 2009
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
LAG 03 Sat Nav Display very dim, but working

Hi All,
I've read through every thread I can find about Sat Nav screen problems, but nothing appears similar to mine - I've just got an 02 Laguna Initiale, with glovebox Carminat & 6 CD in-dash changer - Radio & CD work fine, as does the Sat Nav, but I can only view the screen when I shine a torch into it and look very closely at it - I assume the backlight is gone, and I've had the screen out to check connections, etc, but no change. Using the torch method I've entered the radio code and can see that the Sat Nav is working ok as I could see my correct location. I'm assuming that a replacement screen is needed, but don't know what to look for or where to start looking - is compatability between brands an issue for the screen alone? If I get a replacement do I just need to ensure the right connection on the new screen and plug it in?

If more info is needed, please let me know - I must add that I've learned more about fault fixing from these forums in the last week than in 7 years of owning my old Megane! Every niggling thing on the Lag I've sorted from this site, but this is the last, but most annoying, thing I need to fix, and the only post I've needed to make! Thanks.
johnnyh79 is offline  
  5 Lastest Threads by johnnyh79
Thread Forum Last Poster Replies Views Last Post
Mystery Dashboard Switch in '03 Laguna Initiale Electronics Paul Dengel 9 1548 24th March 2009 08:30 PM
LAG 03 Sat Nav Display very dim, but working Electronics dstorm 8 2127 21st March 2009 01:45 AM
For the best viewing experience please update your browser to Google Chrome