Renault Forums :: Independent Renault forum - View Single Post - Laguna 11 Issues (loads of em)

View Single Post
post #9 of (permalink) Old 28th May 2006 Thread Starter
Junior Member
Join Date: May 2006
Posts: 21
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the advice everyone.

Had the car back and, armed with a little knowledge they were quite happy to help.

The steering rack bushes have been changed but I still have a little noisefrom the front. Keeping an eye on it.

Rear axle bushes changed (apparently), but I really have my doubts. the back end is still a bit wayward, with the car being very unstable braking from 70 ish. The traction control light was flashing yesterday under hard braking and the car just felt like it wanted to spin, so not sure if there's something else worn under there. I plan on getting it up on ramps tomorrow to check.

A new pollen filter has been fitted and the windows now clear much quicker, still steam up first so I might adopt a vw style method for clearing the screen. The blower full on at the floor for 5 seconds to clear any moisture, then onto the screen. if it works for the vw it should work for me..

Other than the handling the car seems really good. Economy isn't bad either, last week I had an "economy" week to work and managed to get the computer to read an average of 53.3mpg. I thought that was brilliant, but I was doing a max of 65 on the motorway. Just shows what can be achieved tho.

Overall now quite impressed with the whole package, not just the looks.
Currently in nev's garage:
2003 Laguna II 1.9DCi/ 1982 R5 GTL 1.1
nev is offline  
For the best viewing experience please update your browser to Google Chrome