Renault Forums :: Independent Renault forum - View Single Post - Clio DCI not turning over

View Single Post
post #3 of (permalink) Old 1st April 2009
Junior Member
Join Date: Mar 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Barners View Post
Hi folks,

Got a problem with a 2001 Clio 1.5 DCI.

When I try and turn the engine over (after the glow plug light goes out on the dash), I get nothing not even a chug, just a click from the dashboard. But I try and turn the engine over without waiting for the glow plugs after the 3rd of 4th attempt I can get it going. Once the engine is warm I can switch it off and switch it back on again after waiting for the glow plugs. Once it's cold again I get the same problem.

Renault suggested checking for corrosion on the battery terminals, which I had and cleaned up but still not luck. Someone mentioned replacing the relay on it???

Any help would be great as it's stuck on my drive way gathering leaves.


i had the same proble check the fuse box one of the fuses might be blown or the best option which fixed my car gt a jump lead the black connect from the negative to one of the metal thing in the engines for earth then start the car it sould start if it does it means youve got a dodgy earth connections am currently drivint the same car ave got the jump lead under the bonnect connected to the battery so it start fine changing it tomorrw
Currently in rizy007's garage:
clio 1.5 Dci
rizy007 is offline  
For the best viewing experience please update your browser to Google Chrome