Renault Forums :: Independent Renault forum - View Single Post - 6x9 speaker installation lag 1 help

View Single Post
post #1 of (permalink) Old 3rd April 2009 Thread Starter
Join Date: Sep 2008
Posts: 42
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
6x9 speaker installation lag 1 help

Hi guys,

Looking for some help here with speaker installation.

Currently got 4 factory fitted speakers in the car with Kenwood W6027 head unit.

Hopefully soon will have some component speakers to replace fronts and have just got an old pair of 6 x 9 in parcel shelf. May have sub & or amp in future when I have some spare money, possibly.

Now, Im looking for help as how to get all the speakers working 2 front, 2 rear and 2 6x9s.

Head unit has red/white rca output for sub/rear speakers. 6x9s have 2 bare prongs on each for wire connections.

Obviously will need speaker wire. But will I need any connectors? Like bullet or spade or whatever?

Was thinking of buying some wire and attaching phono plugs to the ends to connect to H.U. Is that possible?

Any help appreciated!!
Currently in lmersey44's garage:
'02 Citroen Xsara VTR
lmersey44 is offline  
  5 Lastest Threads by lmersey44
Thread Forum Last Poster Replies Views Last Post
Front replacement tyres Wheels & tyres mord 9 1833 19th July 2009 04:21 PM
door speaker cable (crossovers) Electronics lmersey44 2 1171 9th July 2009 09:12 PM
engine cut out :S Engines lmersey44 6 1479 26th May 2009 10:55 PM
8 gauge wire through bulkhead Electronics hondo 3 3370 24th May 2009 09:27 PM
For the best viewing experience please update your browser to Google Chrome