Renault Forums :: Independent Renault forum - View Single Post - Megane 11x84sp - wiper relay

View Single Post
post #1 of (permalink) Old 11th April 2009 Thread Starter
Junior Member
Join Date: Apr 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Megane 11x84sp - wiper relay


Bought a 2004 Megan Sports this week. The car was purchased at auction so a complete check of the electrics was not possible before purchase. The wipers were not required but the wiper switch had been left on. A burning smell was noticed on the drive home. The smell appeared to be cycling on and off over 3 to 5 minutes. Closing the vent and recirculating cabin air did not reduce the smell. When selecting wipers for the first time I discovered they did not work. The wiper switch was turned off and the burning smell didn't re-appear. When checking wiper motor it appears as if the linkages may have ceased at some stage due to water being trapped in area due to blocked drains.There was water trapped in the area under the front windscreen. The power wire for the motor was imersed in water and the shrink wrap where it passed through the left drain had split. There was however no exposer of bare wires to water.The linkages were luricated and the wiper motor tested Ok on work bench. There is no power being supplied to motor. The problem appears to be under the dash. How do I locate the wiper relay, How do I remove the glove box and what else could be the problem. Any ideas much appreciated.
Currently in lisaar's garage:
2004 Megane X84 11 sport 2l turbo
lisaar is offline  
  5 Lastest Threads by lisaar
Thread Forum Last Poster Replies Views Last Post
Megane 11x84sp - wiper relay Electronics Lagdti 1 1443 11th April 2009 09:53 AM
For the best viewing experience please update your browser to Google Chrome