Renault Forums :: Independent Renault forum - View Single Post - 6x9 speaker installation lag 1 help

View Single Post
post #8 of (permalink) Old 19th April 2009 Thread Starter
Join Date: Sep 2008
Posts: 42
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Originally Posted by Gonescenile View Post
I'm sure the wiring is already there below the grilles for the tweeters ..... it's just tied up to keep it from rattling about.
yeah wiring in the tweeters holes only they have molex like connectors assume i'll end up cutting these off if necessary?speakers&tweets have screw down connectors.

Originally Posted by Gonescenile View Post
I believe the common guidance is standard cabling is good for up to 50W RMS,. Anything higher and you'll need to run new cable. But there's no harm in using new cable if you want ...... after all it's your money.
Ok, well components came with own cabling and have external crossover too.
Have rear speakers on the way. Might actually wait to install until i get an amp, rather than having to rewire again.

Originally Posted by Gonescenile View Post
I've Infinity speakers in the front doors, JBL GTO's in the rear doors and a Sony amp running a JBL 12" sub in the boot. Thankfully the Scenic boot is huge and I'm not sacrificing too much space as Azurael suggests.

I think I might give up on the subby and just amp the door speakers soon ....... I'm getting a bit too long in the tooth for all this stuff anyway ........ or so the missus says
Currently in lmersey44's garage:
'02 Citroen Xsara VTR
lmersey44 is offline  
For the best viewing experience please update your browser to Google Chrome