Renault Forums :: Independent Renault forum - View Single Post - 2001 Grand Espace electronic display gremlins

View Single Post
post #4 of (permalink) Old 29th April 2009 Thread Starter
Diamond member
Spanner_Brain's Avatar
Join Date: Apr 2009
Posts: 298
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 0 Times in 0 Posts
Over 18s only! So, now that we have that cleared up...

Had the dash display cluster thingy out, nothing visually wrong with it, all bulbs fine, no sign of anything wrong, opened it up, all cables were properly seated and nothing appeared to be burnt out on the PCB.

Had a peek inside the Bii box, nothing doing there either, dry as a bone and clean as an OCD whistle (oops hope I didn't offend a whistle there LOL, peep peep)

All the earth straps I could find are secure, I found the ECU but decided not to tamper with it just yet.

All the fuses in the fuse box are in good order, both in the engine bay and the passenger compartment.

Took the car for a run this afternoon and when I got back the display didn't reset itself, it appeared straight away every time I turned the ignition.
I even got out and locked the doors, gave it a minute then tried again - it still worked......sure it will be back to square one next time I start it though.

No sign of any leaks (old or new) from any of the sunroofs or Aerial.

That only leaves the immobiliser/key fob/ ECU so I figure it is most likely to be one of those three.

Any thoughts?
Currently in Spanner_Brain's garage:
2001 Grand Espace 2.0 16V privilege, Audi A4 2.8 V6 Quattro

Last edited by Pat.w; 24th May 2009 at 11:23 PM.
Spanner_Brain is offline  
For the best viewing experience please update your browser to Google Chrome