Renault Forums :: Independent Renault forum - View Single Post - 2001 Grand Espace electronic display gremlins

View Single Post
post #20 of (permalink) Old 5th May 2009 Thread Starter
Diamond member
Spanner_Brain's Avatar
Join Date: Apr 2009
Posts: 298
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 0 Times in 0 Posts
Post Been doing the bookworm thing today:

OK, so spent the whole day researching the espace and eventually got into some decent information that I found useful.

I now know that the fault is related to the BII, that is 100%.

The question now is how to figure out if it's:
1: the box itself
2: the related wiring
3: a corroded permanent + feed to the box
4: a dodgy relay(damage/corrosion)
5: the antenna plate/related wiring.

After a lot of consideration I will concentrate on the relays and contacts/earths for everything I can find connected to the box.
Also looking for corrosion at connectors, earths and relays as it may be that the voltage is encountering resistance when it shouldn't be, the resistance changing with incoming voltage and temperature, making the display work better in dry, warm weather, then barely at all in cold wet weather.

Not educated, just guessing because it isn't truly intermittent and the display is losing +12v feed after a while, zeroing out the trip computer.

More fun than knowing bugger all and paying a fortune for them to not know either....

At least I've now got some proper docs to work with, very close to figuring this one out...will end up simply needing a new BII box knowing my luck.
Currently in Spanner_Brain's garage:
2001 Grand Espace 2.0 16V privilege, Audi A4 2.8 V6 Quattro
Spanner_Brain is offline  
For the best viewing experience please update your browser to Google Chrome