Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Electronics - Displaying KMH not MPH

View Single Post
post #50 of (permalink) Old 7th May 2009
Diamond dismember
costeau's Avatar
Join Date: Mar 2009
Posts: 326
Nominated 0 Times in 1 Post
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 44 Times in 41 Posts
If only it was as easy as Espace *sigh*

I've been living in Ireland for the past few years, but every now and then, I head back to Norway on vacation, to visit friends and relatives.
I remember when Ireland went over to the metric system, back in 2005, and Norway has been metric since the 1840's or so.
In order to get to Norway by car from here, the quickest way would be through UK + ferry boats,
therefore, I'd like to be able to switch from metric to imperial and back without any fuss.

(Yes, I should have bought that Espace instead, as you can go back and forth on the units on them,
but the engine is a 3 litre, and in Ireland, you pay through the rectum for the price diffrerence of insurance and road tax alone, compared to a 1.8 litre)

Originally Posted by mike h View Post
Just bringing this thread up again as im trying to gather some information on fixing this problem with the laguna instrument clusters
could the people who have had this problem email me the car details ie

petrol or diesel
and if the instrument cluster has the computer on not
this will help me to solve the problem
mike h: If I had your E-mail address, I would.
However, since I don't, here goes:
Year: 2004
Fuel: Petrol
Trip computer: Yes

Originally Posted by mike h View Post
there are different mcu's in the clusters as if the car has the computer or not, its a 908 in the model without the computer and a newer 9s12 in the models with the computer
if i can see which clusters are having the problem i can source a working mph cluster and read the data from that and program into the faulty cluster, and even replace the mcu if it turns out to be faulty
By having a trip computer, I meant to say that it's more than just odometer, trip counter, and countdown to next service.
This one shows consumption and cruise control settings too.
The bit in the middle are various lamps, and not the dot matrix colour LCD found in higher-spec vehicles.

I am able to put the cluster in test mode (keeping the trip computer button on the wiper stalk depressed while I insert the keycard),
although I haven't got a clue as to what the different "pages" of the trip computer are telling me once I'm in that mode.

When I go into that test mode, the first "page" is just all the LCD segments lighting up, to confirm that they're working (and, of course,
the rest of the cluster goes haywire). The next pages are some blank lines, and some numbers. One of them showed 1.1 at one time, and 2.3 at another.
Another one showed me how much fuel (in liters, and not gallons, to my surprise) was left in the tank.

Any means of configuring anything there without resorting to specialist tools? If I press the trip reset button, the dash just exits the test mode.
Currently in costeau's garage:
2008 Ford Mondeo 2.0 TDCi (Used to have a 2004 Laguna 1.8)
costeau is offline  
For the best viewing experience please update your browser to Google Chrome