Renault Forums :: Independent Renault forum - View Single Post - Sat Nav again!

Thread: Sat Nav again!
View Single Post
post #1 of (permalink) Old 7th May 2009 Thread Starter
Junior Member
Join Date: May 2009
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Sat Nav again!

On my third Laguna II and the latest has sat nav. I have a problem with it and have read the threads but can't find my problem. It may just be a set up issue so here goes.
The sat nav screen is blue, ie no map data. The arrow head cursor is red in a blue circle and this moves across the screen as I drive and points in different directions as you go round corners. The clock is also keeping time.
The cd symbol is red as is the sat dish and TMC.
From this I gather that the shark fin is not at fault. I have removed the head unit from above the radio, left it disconnected for 5 min and replaced it. This has not changed anythin in the 1/2 hour or so I have been driving. The disc in the CD is dated 2003 and not scratched. I put a cd cleaner disc in and this was ejected after a few minutes so I think the unit is ok.
Any idea what the problem is or what else I can try?
Currently in poorpeet's garage:
Lag 2 1.9 dci
poorpeet is offline  
  5 Lastest Threads by poorpeet
Thread Forum Last Poster Replies Views Last Post
Downloaded map info. Safe? Electronics Horatio 1 723 9th May 2009 08:20 PM
Sat Nav again! Electronics poorpeet 6 1031 7th May 2009 09:17 AM
For the best viewing experience please update your browser to Google Chrome