Renault Forums :: Independent Renault forum - View Single Post - Car Audio/Clock/Temp Display

View Single Post
post #1 of (permalink) Old 13th May 2009 Thread Starter
Junior Member
mminoletti's Avatar
Join Date: Jan 2007
Posts: 23
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to mminoletti
Car Audio/Clock/Temp Display

1.6 Laguna Sport S reg 1998

I went to change the Bulb in the Display as one had go out. I took the blown bulb one out and didn't replace it as i didn't have any. (Should be three in all)
When i plugged everything back in, i got a blank screen.
I have replaced the Display with another one and still the problem is there.
Today i brought a replacment Radio thinking it could be that as read in another thread but no, still blank.

The funny thing is, if i hold a light to the display i can see the text. The bulbs in the replacment Display are fine but seem not to be getting any power. Does anybody have any idea what the problem could be before i have to take it somewhere to be fixed.

Thanks Martin
Currently in mminoletti's garage:
Renault Laguna 1.6 16v RT Sport 1998

Last edited by mminoletti; 13th May 2009 at 04:11 PM.
mminoletti is offline  
  5 Lastest Threads by mminoletti
Thread Forum Last Poster Replies Views Last Post
Car Audio/Clock/Temp Display Electronics eddiejago 3 1114 13th May 2009 03:44 PM
Renault Scenic rear Wiper Electronics madtimes 8 5626 1st October 2008 09:08 PM
New Laguna Headlights Electronics mminoletti 12 2126 10th August 2008 07:09 PM
For the best viewing experience please update your browser to Google Chrome