Renault Forums :: Independent Renault forum - View Single Post - P reg Megane electrical Armageddon

View Single Post
post #5 of (permalink) Old 25th May 2009
Diamond member
Spanner_Brain's Avatar
Join Date: Apr 2009
Posts: 298
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 0 Times in 0 Posts
LOL, may be worth parting it out as the scrappy will likely only give you 25 quid for it or nothing at all....that said I got rid of a car not too long ago and they paid me 100 quid for it, look in the yellow pages

Don't give up though!, it may still be something fixable think of it as a challenge!!!

Take what ChrisM said, it may be as simple as an earth, at least check that the battery negative is properly connected at both ends, check the wires going to the alternator for damage, also check any other visible/exposed wiring in the engine bay, check the interior fusebox for anything out of the ordinary, check the earth strap to the injection ECU (the main ECU - in the engine bay) if it's suspect - put a heavy gauge wire from one end to the other of the strap but don't replace the actual strap if you know what I mean.

I'll send my old man an email, he's a wizard and has seen it all, he's away to Canada the now but he may have experience of such a problem and have some suggestions, he says it's boring there so it will give him something to think about.

Hang in there
Currently in Spanner_Brain's garage:
2001 Grand Espace 2.0 16V privilege, Audi A4 2.8 V6 Quattro
Spanner_Brain is offline  
For the best viewing experience please update your browser to Google Chrome