Renault Forums :: Independent Renault forum - View Single Post - Computer display not changing Clio2 Sport 1.4 W reg

View Single Post
post #2 of (permalink) Old 5th June 2009 Thread Starter
Diamond member
Join Date: Sep 2007
Posts: 164
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 24
Thanked 8 Times in 8 Posts
Originally Posted by wozz View Post
Hi, I have trawled the forum for an answer to this so if I've missed it my apologies. (There was one similar post but no real resolution so I can only hope)

My (newly acquired) Year 2000 Clio 1.4 sport has the computer which displays mpg, range etc. (The specification says it has one)
After switching on the ignition the "ooooo oil " message appears for approx 30 sec it then changes to odometer, and I cannot get the display to change to any of the other measurement readouts, it is stuck on odometer and trip miles. Trip miles can be zeroed by pushing the button below the speedo.
I have done the dash reset thing (if that's what it is?) by holding the above button in for some seconds and then all the dials become possessed by a strange and mysterious force and move of their own free will! (I think I've been watching too many films!)

Repeated pressing on the button on the end of the rh stalk, both after driving for a while and without driving do nothing. The previous owner tells me it definitely worked many years ago but he wasn't interested in it so, to quote his words "I switched it off" He probably meant that he left it on mileage but I cant be sure as I don't know if there is a way to dis/enable it. I have tried all sorts of combinations of buttons to no avail.
What have I stupidly overlooked?
Many thanks to all in the forum.

(PS I just tried a later clio of about 2005 vintage and it can be changed through all the different readings after the ignition is switched on, driving it isn't even necessary)
edit to the message- When the dash test is performed do you have to leave it to get to an end itself or do you just turn the key off, which stops the test? I didn't wait for longer than about a minute and it was still cycling so I turned it off- I just wondered if that was relevant?- end edit
Currently in wozz's garage:
2000 Clio 1.4 8v sport
wozz is offline  
For the best viewing experience please update your browser to Google Chrome