Renault Forums :: Independent Renault forum - View Single Post - TDC Sensor Replacement (with pictures!)

View Single Post
post #170 of (permalink) Old 6th June 2009
Join Date: May 2009
Posts: 36
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Megane Scenic T reg 1.6 RT Alize tdc sensor

Hi folks, I'd just like to thank everyone who has contributed to this post and especially those with pictures as it's helped me loads.

I was having the well known issue of crappy idling, stalling at lights when in neutral and the worst of the bunch the issue of turning over but refusing to start, all of which were starting to become more frequent.

I've got a Megane Scenic T reg 1.6 RT Alize which has the K7M engine and I've just cleaned and replaced the TDC sensor after reading this thread and although it's too early to tell and could just be my imagination, I am sure that already I have noticed a marked improvement in how the engine is running and it seems to be firing up first try as it was when I bought it back in November. Time will tell but it's looking good so far.

One thing I am extremely happy about is that I was expecting it to be an awkward git to get to as so many seem to be but on the K7M engine there is quite literally nothing to move to get to it and access was a dream come true. In total it only took me 10 mins to find, clean and replace the sensor after giving it a squirt of good old WD40 which I'm guessing is as much for rust prevention as anything else. The sensor itself I'm guessing must have been replaced just before I bought the car as the tip is still shiny but there were some small metal filings on the end so I'm guessing that's really all it takes to throw it off.

Anyway, thanks again to all and happy motoring. :-D
Currently in farbinjudder's garage:
Megane Scenic 1.6 RT Alize 1999 T reg (avec MOT, lol). :-)
farbinjudder is offline  
For the best viewing experience please update your browser to Google Chrome