Renault Forums :: Independent Renault forum - View Single Post - Renault Scenic 2 - Instrument Cluster Failure

View Single Post
post #17 of (permalink) Old 27th June 2009 Thread Starter
Junior Member
Join Date: Apr 2008
Posts: 22
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by sad scenic owner View Post
just tried what you said mate about the terminals didint work now i have nothing no clicking noise the electrics dont work now and the car was locking itself then wouldnt lock when i tried to lock it, could i need a new battery ? these cars really are a piece of s**t they should be recalling all the models with dash faults surely the dashboard should out last the car i know you said not starting isnt anything to do with the dash but its a fault that should have been caught on by renault they were quick enough to take the 8000 of me i really dont know what to do about this like i said before i cant get it to a garage because it wont start and i dont know a mechanic
hi again , it could well be the battery is flat altogether
when i did mine i found out that the actualy contacts on the connections were crap, i replaced renault ones with standard ones and since have had no problem, i too was getting clicking sounds and then sometimes nothing the doors wouldnt lock and sometimes even the window wipers starting going on their own,
i would strongly advise changing the connections alltogether
p.s when you hear the clicking thats when the connections are making slight contact but if ure getting nothing now after checking them then i would say it is definatly the connections
Currently in darren11372's garage:
scenic 2004 1.5 dci
darren11372 is offline  
For the best viewing experience please update your browser to Google Chrome