Renault Forums :: Independent Renault forum - View Single Post - Clio 1.2 8v (NOT 16V) Ignition Coil

View Single Post
post #1 of (permalink) Old 7th July 2009 Thread Starter
Junior Member
Join Date: Jul 2009
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio 1.2 8v (NOT 16V) Ignition Coil


Can anyone help me? My girlfriend's beloved Clio 1.2 is on an 02 plate and is a 8v alve not a 16 valve. The car starts OK until 2 weeks ago but has been running rough and seems to have a lack of power even for the 1.2.

The coil light is on and the serv light also. I could do with any info on how to get these off if anyone has this knowledge.

We suspected it's the coil pack which is a 4 bolt fitting version which is to blame. We did the plugs and air filter. But did also think it could do with a fuel filter change but we couldn't find it.

We really wanted to know if the 16v and 8v is the same item for the 1.2 02 as I'm not keen to purchase anything from the "main stealer" - they were not the most helpful souls on earth.

If anyone has any other suggestions please let us know as this problem is getting worse and worse now.

Thanks - Paul & Alison
Currently in pablo1572's garage:
renault clio 1.2 8v
pablo1572 is offline  
  5 Lastest Threads by pablo1572
Thread Forum Last Poster Replies Views Last Post
clio locking with reason...please help. Electronics pablo1572 0 370 26th January 2014 09:38 PM
clio central locking? Please Help! Electronics pablo1572 0 626 17th January 2012 07:57 PM
Clio 1.2 8v (NOT 16V) Ignition Coil Electronics dave_mezza2006 3 3428 7th July 2009 11:49 AM
For the best viewing experience please update your browser to Google Chrome