Renault Forums :: Independent Renault forum - View Single Post - Right Front Indicator Issue

View Single Post
post #1 of (permalink) Old 13th July 2009 Thread Starter
Junior Member
Join Date: Jul 2009
Posts: 21
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Right Front Indicator Issue

Hi guys, i'm new to the forum and have limited knowledge of cars so any step by step guides would be very much appreciated!

I have also searched long and hard before submitting this query!

I have just bought a Renault Clio Alize 1.4 2001 (X) and I have an issue with the front right indicator.

When I indicate right the dash display for the indicator signs ( <-- & --> ) both appear and flash at double speed. Both the side, and the back bulbs flash but the front does nothing.

This is what I would expect to happen if the front bulb has blown so my first post of call was to replace it! Same problem!

I can hear the double speed clicking of the indicator so I know the ticker is ok and I have looked in the casing for the bulb and can see no corrosion or anything that may restrict the flow of electricity. Looks like new!

I don't know enough about cars to diagnose further. The left indicator is working perfectly.

If there is anything I can do to help anyone further let me know!

Please help!
Currently in d-pearson's garage:
2001 (X) Renault Clio Alize 1.4
d-pearson is offline  
  5 Lastest Threads by d-pearson
Thread Forum Last Poster Replies Views Last Post
Clio Mk2 Electrics Electronics 5 1918 19th April 2010 09:18 AM
Clio Mk 2 Brakes on Permanently Brakes/Hubs ChrisR763 4 1227 18th July 2009 07:41 PM
Clio II Temperature Display Electronics Truckbusuk 9 4334 13th July 2009 08:00 AM
Right Front Indicator Issue Electronics 27 3353 13th July 2009 07:49 AM
For the best viewing experience please update your browser to Google Chrome