Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - Post Purchase Views

View Single Post
post #11 of (permalink) Old 15th July 2009
Platinum member
mord's Avatar
Join Date: Jun 2009
Posts: 5,250
Nominated 3 Times in 11 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 47
Thanked 514 Times in 490 Posts
re. ragged running on low revs.
i had a similar problem on my laggy1(1.8/2.0 8v) when i bought it. i chucked on a ECO-TEK thingy which basicly consists of a variable set sprung air bleed valve which bleeds air into the inlet manifold via the manifold-master brake servo pipe. suposedly it disrupts the air flow (creates turbulance) in the manifold.
before i fitted it, i suffered hesitation, poor idle, flat spots between 1500-2500. after fitting it ran much better with no problems, except it is running leaner, so is slightly hotter on the temps.

i have no idea if it works ok on a laggy2 1.8-2.0 16v
i've just had LPG fitted so am not looking to make more problems.

other than that i suggest you clean the MAP sensor and make sure its not got any oil breather pipes blocked.

as a hint, dont fit gas shocks on the car unless you want a harder ride, it was very nice and smooth on oil shocks, but i think it might have been a mistake to chuck on the gas ones.
Currently in mord's garage:
The CreditCard Holes sooo DEEEEP NASA have put up warning signs about a black hole on the Driveway: update, the driveway and home have fallen in...

Last edited by mord; 15th July 2009 at 08:55 PM.
mord is offline  
For the best viewing experience please update your browser to Google Chrome