Renault Forums :: Independent Renault forum - View Single Post - '52 clio main battery fuse probs

View Single Post
post #3 of (permalink) Old 28th July 2009
Diamond member
Hammer-ter's Avatar
Join Date: Jun 2006
Posts: 179
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 14 Times in 13 Posts
Originally Posted by jude01 View Post
Husband fired up his clio this morning but had left in gear so jumped forward then stalled! Tried to restart but nothing happening - just clicking not turning over. Having spoken to garage they think he's blown the main battery fuse. Have trawled the haynes manual but can't find any info on how to replace this - anyone have any ideas????? you're help would be much appreciated, would rather do self than fork out more money at garage - think the car is doing it deliberately as it knows it's being replaced at the end on this month
I don't believe there is a fuse between the battery and the starter motor on the Clio.

If the battery is old ?? then the extra current taken when starting in-gear may have been enough to crack a plate inside the battery & finish it off - in which case new battery would be needed.

Alternatively, the extra movement in the engine mountings as the engine jerked in reaction to starting may have loosened an engine earthing strap.

Can you put a meter across the battery to get a voltage reading? Do the headlights still work?

Answers to above would be helpful in sorting this
Currently in Hammer-ter's garage:
Scenic III 1.2 TCe 115 2012, Clio III 1.2 TCe 2011, Peugeot 207 1.6 HDI90 2009
Hammer-ter is offline  
For the best viewing experience please update your browser to Google Chrome