Renault Forums :: Independent Renault forum - View Single Post - Its all going wrong!!!

View Single Post
post #1 of (permalink) Old 15th June 2006 Thread Starter
Junior Member
Join Date: Sep 2005
Posts: 13
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Its all going wrong!!!

Right Boyz and Girlz help me out here!

Iv had a hell of a week which is just getting worse, problem 1:

Iv been having really bad squeaky brakes for the past 3 or 4 weeks which have only been getting worse, that I can put up with however, as of this evening the squeaking is still happening when I have completely removed my foot from the brake, while approaching a set of lights I had as good as come to a stop and was just slightly rolling with my foot no where near the brake and the squeaking was horrendous - any ideas? the best I could figure was that the brake pad was still in contact with the disk but surely not???

Problem 2:

Now this one is comical and had the lads in the office in fits of laughter, when I put the car in to reverse my rear wiper starts to go!!! This happened a couple of days ago when we had nothing but scorching sun and certainly no use for the wipers, I checked to make sure that I hadn't switched them on and I hadn't. I tested it by knocking it out of gear and the wiper stopped and giving it various lengths of time before putting it back in to reverse and still its EVERY time I put it in to reverse. The reverse lights still come on though. any ideas which stops me from visiting Wests Renault who are next to bloody useless would be great.

Cheers, Trouty.
Currently in Trouty1980's garage:
1.4 Megane '54'
Trouty1980 is offline  
  5 Lastest Threads by Trouty1980
Thread Forum Last Poster Replies Views Last Post
Its all going wrong!!! Cars & motoring davesss 11 1827 15th June 2006 03:27 AM
For the best viewing experience please update your browser to Google Chrome