Renault Forums :: Independent Renault forum - View Single Post - Espace III help please

View Single Post
post #5 of (permalink) Old 22nd August 2009 Thread Starter
Junior Member
Join Date: Jul 2009
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
HI Guys, thanks for your suggestions. I will have a look at the windows tomorrow. As for today, it was speedo day. I jacked up the car and found the speedo sender unit at the back of the gearbox. It was in a terrible state so I cleaned it all up, cleaned the 3 pins and all. I cleaned up the wires as well. Washed the connectors in petrol and blew them clean with compressed air. Put it all back and nothing, nada!. So out it all came again, I added long leads to the sender so I was not fiddling under the car the whole time. I picked up a spare digi display from the breaker the other day so I connected that as well. Still nothing. When I connect my multimeter to the pins on the sender I do get a reading but have no idea what it should be. I tried to trace the wires back to the display, no luck their either. I do not get any warning lights with the ABS, the red one comes on when I start the car, but goes off soon after. I alos get the airbag warning, but again I will deal with that later. For now all I want is the Speedo. Is it possible to buy a sender unit? Does anyone know where the wiring goes to?

Thanks and regards
Currently in russeleion's garage:
Escort 1.8 16v and totally useless Espace 2.2td
russeleion is offline  
For the best viewing experience please update your browser to Google Chrome