Renault Forums :: Independent Renault forum - View Single Post - Megane 2 wiper problem

View Single Post
post #2 of (permalink) Old 27th August 2009
Junior Member
Join Date: Aug 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by TJ Megane View Post
Hi all.
I'm new here and i've never had a Renault before so please go easy on me!
Got a 2003 megane 1.9 dci dynamique 3 door hatch and the wipers have stopped working. Theres nothing on speeds 1&2 but when I turn them on to fast and give the wipers a push start they work, when I stop them they don't go back to the park position. Any ideas?
I've just spent the last three days trying to resolve exactly the same problem on the same model and have finally solved the problem.

The wiper motor was damaged by the ingress of water and the result was that one of the three brushes was failing to connect with the commutator. The commutator was in a pretty dirty state as well.

To check whether this is the problem, check the four pins in the motor socket for continuity. You will probably find that you'll get continuity from the earth (black wire on plug) and one other pin but no more.

to go further, you will need to remove the motor assembly and dismantle the motor. Don't try to remove the socket but you will need to remove the gear cover (the plastic bit with four clips. It's stuck on with some kind of sealant and will need careful prising off. You will then need to remove the two screws holding the motor cover and again this is stuck on with sealant. I had to use a very sharp chisel to start the split.

The spring clip then needs to come off the output shaft and you'll then be able to take out the gears and remove the armature for cleaning. My third brush was simply stuck and was easily freed off and cleaned up. I used silver polish on the commutator.

The wipers are back to normal now apart from the auto wipe function which I appear to have disturbed when taking out the engine multiplex box! The auto loght function has failed as well which hopefully will give a clue.

Hope this helps
martindevoy is offline  
For the best viewing experience please update your browser to Google Chrome