Renault Forums :: Independent Renault forum - View Single Post - Bizarre Electrical fault

View Single Post
post #1 of (permalink) Old 6th September 2009 Thread Starter
Junior Member
Join Date: Nov 2007
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bizarre Electrical fault

2003 Megane 2 1.4 Diesel.
Had a flat battery a couple of weeks back, left the lights on (but they should switch off when locked?). Slave started the car but since then have a number of odd faults;
Window washers/touch wipe don't work (but wipers do off the same switch, just the 'pull' functions defective)
Heated rear window and Airconditioning won't work (lights do not illuminate in switch),
Cigarette lighter not working,
The Time and Temp display won't come on unless the Radio is on.
There are probably a few other oddities. Checked all fuses, disconnected and reconnected battery (this was necessary to check the fuses anyway!) and all connectors.
In an older vehicle I'd suspect an earth connection but there are hundreds to chose from in the Megane and most are inaccessible. I'm suspecting the Interior Control Module but before I shell out, is there any master reset function or maybe something I've missed? Any help appreciated.
Currently in Scolopax's garage:
Megane II Expression 1.5 Diesel
Scolopax is offline  
  5 Lastest Threads by Scolopax
Thread Forum Last Poster Replies Views Last Post
Bizarre Electrical fault Electronics Scolopax 9 1366 6th September 2009 02:33 PM
Alternator Electronics Scolopax 2 641 23rd November 2007 06:03 PM
For the best viewing experience please update your browser to Google Chrome