Renault Forums :: Independent Renault forum - View Single Post - service light + check injection

View Single Post
post #10 of (permalink) Old 16th September 2009 Thread Starter
Junior Member
Join Date: Aug 2009
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Rentech it starts with no probs and seems fine just press and turns over and starts in no time. and it seems to sound nice on tick over now, it was a bit lumpy or low tick over but seems ok now, its when i drive it blows this smoke and it makes a noise that i did think was slight blow on exhaust but its tinkky or tatty if you know what i mean tappity, and then there is the light on, will the diag show what that this light is coming on and if so would it show what it is?
for some reason i get the feeling its either the injecotrs or pump, dont know why just my guess,it drove home on m4 in 4th as they advised and it would go up to 80 no probs and in 5th going to 90 plus (on private m4 road that is) and seems to have guts but it just dont feel right or sound right and the smoke and light show its not right but did get the feeling like i was being pushed out of the door,i hope the main dealer get this sorted if not i hope they will tka eit back off me and give me another vehicle as these probs were there when i bought it, in fact i rang them on the way home to tell them.
thanks again for trying to help me i am greatful and i can tell them that i know a little.
gumboots is offline  
For the best viewing experience please update your browser to Google Chrome