Renault Forums :: Independent Renault forum - View Single Post - Megane II Amber Service light

View Single Post
post #7 of (permalink) Old 22nd September 2009
Junior Member
Join Date: Sep 2009
Posts: 15
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 7
Thanked 1 Time in 1 Post
Thanks ...

Originally Posted by dave_mezza2006 View Post
Could be the coils , they are a common fault on the 16v engines these day's Im afraid. I dont think the TDC sensor being at fault would bring on the toxic fumes warning light.

The redex wouldnt cause this problem, Im sure. If you can, get the 4 new coils and change the spark plugs at the same time. That should see you right.
Thank you very much for your input. It is greatly apppreciated. Mercifully, the problem is in hand, thanks to Renault. Phoned Renault Customer service. Cant believe the service I am getting! Cant praise their response enough! Excellent attention I am getting from Renault. Excellent is all I can say. Explained the symptoms to them. Explained that I am a pensioner and of ill health, (which is true by the way), that I was not pulling a fast one on them, that the 4 year old car has done only 18,000 miles, been serviced by Renault dealer, and can do without this aggro. Informed them that I have inspected one of the coils , and it is a Sagem, though am not sure if it is from the dodgy batch. Renault agreed that it is wise not to drive it, and have arranged for its collection tomorrow, for them to look at. This is superb, old fasioned service, which I thought did not exist any more!. No other word for it.Thank you Renault, thanks to this forum too for having all the experts to give advice and help.
zapata123 is offline  
For the best viewing experience please update your browser to Google Chrome