Renault Forums :: Independent Renault forum - View Single Post - No Glow light when starting

View Single Post
post #9 of (permalink) Old 22nd September 2009
Diamond member
regie's Avatar
Join Date: Sep 2009
Posts: 170
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 5 Times in 5 Posts
Smile Glow plug light

Firstly check the heater/glow plugs. connect the test light to the live side of the battery so everything earth you touch with the probe end lights the test light. remove the electrical connections from the plugs then touch the glow plugs in turn (does not matter which order). the test light should light on all 4 heater plugs. If that is O.K. connect the test light plug to earth get someone to turn on the ignition and while you test for a live at the heater plug connection on each glow plug wire the test light should light for a few seconds on each wire(from cold). If that is O.K. its time to get serious you will need a wiring diagram or a main dealer for the rest of the electrical checks but first try this. I am assuming the car is a JA05 Scenic 1 Phase II run the engine get someone to look at the instrument panel locate the pressure regulating solenoid on the back of the high pressure pump and disconnect it. When the solenoid is disconnected the injection light should come on. Please be aware that when the wire is disconnected the rail pressure can exceed 1400bar but the engine will stall so it will only be for a split second. If the light does not light then its wiring diagram time!!
Currently in regie's garage:
2007 Scenic II 1.5dci Scenic 1 Phase 2 1.6 Auto
regie is offline  
For the best viewing experience please update your browser to Google Chrome