Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - Model Spec Differences

View Single Post
post #11 of (permalink) Old 29th September 2009
Junior Member
Join Date: Sep 2009
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Thankyou Thankyou...

Originally Posted by dave_mezza2006 View Post
Yup, Rentechs right, your better off without them. I had problems with the tyre sensors and my xenons (bulbs and pop up washers). Plus the auto wipers aint all that... a defo step backup from the variable intermittent wipe on the Lag 1 I had before it.

So you are defo better off without them IMO. both of you, i really didn't think of it like that I've come over from a Nissan Skyline where EVERYTHING worked (and it was over 13yrs old!!).

I love it... you think of all you dont have... i just assumed that on a 5 yr old car (which isn't old lets be honest) everything did as it should... after all it is 2009 not 1989 lol..

I had no idea xenons were so expensive, and regards the windscreen... Why has mine got a load of black dot things around the mirror about 6 inches. i thought they were a sensor of some sort.
Also, theres some sort of sensor under the windscreen on the dash.

Oh, i've just noticed... shouldn't the climate control screen light up at night... coz mine doesnt'... bloody hard to see what you've set in the dark it is ))

thanks again my friends
Currently in bazza825's garage:
2004 Renault Megane CC 2.0vvt Privilege
bazza825 is offline  
For the best viewing experience please update your browser to Google Chrome