Renault Forums :: Independent Renault forum - View Single Post - Installing Amp Sub to 2006 Clio

View Single Post
post #1 of (permalink) Old 2nd October 2009 Thread Starter
Junior Member
Join Date: Oct 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Installing Amp Sub to 2006 Clio

Can anyone help, I've recently bought a 2006 Clio 1.5 DCI Dynamique, taking the Sub, Amp and Headunit out of my previous car, and I'm having a huge problem figuring out how to wire it all in.

On my previous car (C2) there was a little gromit type thing placed convieniently inside the car, so that the power lead could easily be fed through and connected to the battery, whereas on the clio I can't feed the lead through anywhere that I can see!

Does anyone know how to do this, or has anyone done it to their Clio? The C2 seemed a doddle to do in comparison! (To be honest I had loads of help from a mate with the C2)

I've also been left with the plastic/rubber part that runs along the bottom of the windscreen (drivers side) sticking up and not running flat against the windscreen! I've got the little white clip that attaches to this plastic/rubber part, however once the clip is in place and I try to push it down the clip just pings off and falls into the cavity inside the car. I then have to fish it out with a couple of screwdrivers or something!

I have looked around the forum but I can't seem to find any installation info relating to the Clio I have (I don't know what 'mark' it is, I would guess mark 3, all I can say is its the newer shape one with "guide me home" headlights (what a nifty little feature!)

Currently in Seabass1985's garage:
Renault Clio III 1.5 DCI Dynamique & Kawasaki Z1000
Seabass1985 is offline  
  5 Lastest Threads by Seabass1985
Thread Forum Last Poster Replies Views Last Post
Installing Amp Sub to 2006 Clio Electronics ollyc 4 1836 2nd October 2009 04:38 PM
Hello Welcome to RenaultForums davesss 4 731 2nd October 2009 08:22 AM
For the best viewing experience please update your browser to Google Chrome