Renault Forums :: Independent Renault forum - View Single Post - Glow Plug / electrical fault light + power loss

View Single Post
post #1 of (permalink) Old 15th October 2009 Thread Starter
Junior Member
Join Date: Oct 2009
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Glow Plug / electrical fault light + power loss

Hello all. New to this please forgive me.

I really don't know what to do. Two days ago, I paid 2200 for a Renault Laguna Tourer 1.9 Dci Dynamique bought from a local garage. It has highish miles (122000) but a full (independant) service history so wasn't worried. (Cam belt done at 80000 miles, no repair reciepts with the car.)
Following morning, I was driving to work and the glow plug light came on and the car lost power. I got to work, called the garage and they said bring it in and we'll put in on the diag machine. I don't remember exactly what the fault code said, but was something along the lines of "Heater control circuit high(??)".
He reset it and said it could just be a glitch. However this morning, in exactly the same place on route to work, the same thing happened. I've left the car with them now for a more thorough investigation but after doing some research on various forums, I'm starting to get worried. Could the turbo be on the way out? Should I ask them to take the car back? I've used my savings to buy the car and certainly can't afford a hefty repair bill.
Currently in Punts's garage:
Renault Laguna 2 1.9 Dci dynamique tourer
Punts is offline  
  5 Lastest Threads by Punts
Thread Forum Last Poster Replies Views Last Post
Glow Plug / electrical fault light + power loss Electronics Punts 2 1460 15th October 2009 09:23 AM
For the best viewing experience please update your browser to Google Chrome